ДомойСтрелочка
Пресс-центр
Стрелочка
Настройка роутеров
СтрелочкаНастроить роутер Microtik под московский Билайн.

Настроить роутер Microtik под московский Билайн.

распаковка микротика

Конфигурация MicroTik RB751U-2HnD

Распаковываем MicroTik RB751U-2HnD. Подключаем роутер в сеть и билайновский кабель вставляем в порт PoE. Дожидаемся двух индикаторов на роутере со значками WiFi и «1». Открываем список беспроводных сетей нажатием в трее на значке сети. Подключаемся к незащищенной сети MicroTik. Всплывет системное окно Виндовс, которое попросит вас указать тип соединения — выбираем «общественная сеть».

Открываем браузер и набираем адресной строке 192.168.88.1 и вы сразу оказываетесь в веб интерфейсе webfig. Можно работать по этой инструкции и с этим интерфейсом, но нам будет гораздо удобней настраивать через специальную утилиту winbox, загрузить которую мы можем с встроенного в роутер хранилища. Посмотрите внимательно, с левой стороны есть вертикальное меню, где 4-я снизу ссылка, с одноименным названием, дает возможность быстро скачать программу winbox.


Перед началом всех настроек, нам необходимо узнать адреса серверов билайн, которыми мы будем пользоваться. Жмем пуск и в поиск вводим cmd.

Копируем:

nslookup tp.internet.beeline.ru

089*******

85.21.192.3

85.21.0.246

Вставляем правой кнопкой мыши. В моей подсети адрес сервера билайн определился 85.21.0.242. В некоторых подсетях адреса может быть два сервера, например 85.21.0.93 и 85.21.0.98. В таких случаях я их записывал как 85.21.0.0/24.

Итак, загрузили и открываем winbox. В появившимся окне, оставляем все по умолчанию и жмем Connect. Видим программный интерфес winbox и первое модальное окно RouterOS Default Configuration. Жмем Ok и переходим к быстрым терминальным настройкам, нажав на пункт меню New Tetrminal.

Далее копируем:

/ip dhcp-client print detail

и вставляем в терминал правой кнопкой мыши и жмем Enter. И получаем

Flags: X — disabled, I — invalid

0 ;;; default configuration

inter add-default-route=yes default-route-distance=1

use-peer-dns=yes use-peer-ntp=yes status=bound address=10.96.27.177/21

gateway=10.96.24.1 dhcp-server=83.102.233.204 primary-dns=85.21.192.3

secondary-dns=213.234.192.8 expires-after=6d23h59m20s

Из этой записи нам нужны значения primary-dns и secondary-dns для следующей терминальной команды, сформированной из этих значений. Внимание! Копируем команду, подставляя свои значения, и вставляем в терминал:

/ip dns set servers=primary-dns,secondary-dns allow-remote-requests=yes

У меня получилось:

/ip dns set servers=85.21.192.3,213.234.192.8 allow-remote-requests=yes

Следующим шагом нам необходимо посмотреть значение gateway командой:

/ip route print detail

Моё значение:

gateway=10.96.24.1

Формируем следующую команду и подставляем свои значения. Копируем первую команду и вставляем:

/ip route

Копируем вторую команду и вставляем:

add comment="vpn servers subnet" dst-address=nslookup tp.internet.beeline.ru gateway=gateway

У меня получилось:

add comment="vpn servers subnet" dst-address=85.21.0.246 gateway=10.96.24.1

Закрываем терминал и открываем заново (к сожалению, ваш покорный слуга лениться найти команду для перехода на верхний уровень и использует такой костыль). Теперь нам нужно сконфигурировать стандартное PPPoE соединение билайна.

Копируем первую команду и вставляем:

/ppp profile

Далее:

add change-tcp-mss=yes comment="" name=beeline-l2tp only-one=default remote-address=192.168.200.1 use-compression=no use-encryption=no use-vj-compression=no


Теперь конфигурируем l2tp соединение, в котором необходимо указать логин и пароль от своего личного кабинета. Каждый подставляет свои значения!

/interface l2tp-client add name=beeline-l2tp profile=beeline-l2tp user=089ЛОГИН password=ПАРОЛЬ connect-to=nslookup tp.internet.beeline.ru disabled=no add-default-route=yes max-mru=1420 max-mtu=1420 mrru=disabled

У меня получилось:

/interface l2tp-client add name=beeline-l2tp profile=beeline-l2tp user=089****585 password=lk089****585 connect-to=85.21.0.246 disabled=no add-default-route=yes max-mru=1420 max-mtu=1420 mrru=disabled

Копируем в терминал и жмем Enter. Закрываем терминал и открываем его снова. Теперь необходимо добавить правило NAT для интерфейса VPN следующей стандартной командой:

/ip firewall nat add out-inter chain=srcnat action=masquerade

Чтобы иметь выход на DNS сервера билайна до подключения к L2TP-серверу, добавляем маршрут по умолчанию:

/ip route add gateway=nslookup tp.internet.beeline.ru distance=20

У меня получилось:

/ip route add gateway=85.21.0.246 distance=20

Все вроде бы все настроили, но ёпта, популярные сайты не открываются! Карячим в терминале дальше стандартной командой:

/ ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn tcp-mss=1453-65535 action=change-mss new-mss=1360 disabled=no


Теперь добавим немного скриптов, для того что бы роутер при разрыве соединения сам переподключался и занимался самопрофилактикой:

/system script

Далее:

add name=beeline-l2tp_soft_refresh policy=ftp,read,write,winbox source=":local\

\_interface \"beeline-l2tp\"\r\

\n:local vpnserver \"tp.internet.beeline.ru\"\r\

\n#:log debug message=\"Soft resolv script run\"\r\

\n:if ([/interface l2tp-client get \$interface running] = false) do={\r\

\n :log info message=\"VPN down. Refreshing\"\r\

\n /ip dns cache flush\r\

\n :local \"current-ip\" [:resolve \$vpnserver]\r\

\n :local \"old-ip\" [/interface l2tp-client get [/interface l2tp-client\

\_find name=\"\$interface\"] connect-to]\r\

\n :if (\$\"current-ip\" != \$\"old-ip\") do= {\r\

\n :log info \"VPN Server changed IP address from \$\"old-ip\" to \$\

\"current-ip\"\"\r\

\n /interface l2tp-client set [/interface l2tp-client find name=\"\$i\

nterface\"] connect-to=\$\"current-ip\"\r\

\n }\r\

\n}"

add name=beeline-l2tp_refresh policy=ftp,read,write,winbox source=":local inte\

rface \"beeline-l2tp\"\r\

\n:local vpnserver \"tp.internet.beeline.ru\"\r\

\n:log debug message=\"Hard resolv script run\"\r\

\n#:if ([/interface l2tp-client get \$interface running] = false) do={\r\

\n /ip dns cache flush\r\

\n :local \"current-ip\" [:resolve \$vpnserver]\r\

\n :local \"old-ip\" [/interface l2tp-client get [/interface l2tp-client\

\_find name=\"\$interface\"] connect-to]\r\

\n :if (\$\"current-ip\" != \$\"old-ip\") do= {\r\

\n :log info \"VPN Server changed IP address from \$\"old-ip\" to \$\

\"current-ip\"\"\r\

\n /interface l2tp-client set [/interface l2tp-client find name=\"\$i\

nterface\"] connect-to=\$\"current-ip\"\r\

\n }\r\

\n#}"

И еще один скрипт:

/system scheduler

Далее:

add disabled=no interval=1s name=beeline-l2tp_soft_refresh on-event=\

Далее:

beeline-l2tp_soft_refresh policy=reboot,read,write,policy,test \

Далее:

start-time=00:00:00

Далее:

add disabled=no interval=0s name=beeline-l2tp_refresh on-event=\

Далее:

beeline-l2tp_refresh policy=reboot,read,write,policy,test \

Далее:

start-time=05:00:00

Далее идем во вкладку IP и выбираем вкладку DHCP Client. В открывшимся окне, два раза нажимаем на единственной записи и зырим строчку Default Route Distance, где сейчас значится значение 1. Объясняем роутеру цифрами, что дистанция нам нужна 10. Жмем Apply.

Осталось настроить безопасность беспроводного соединения, дать имя своей сети и запоролить вход в админку роутера через веб интерфейс.

Переходим по ссылке в меню System и жмем на ссылку User. В открывшемся окне User List значится единственная запись admin. Жмем по ней дважды. В новом открывшемся окне в самом низу жмем по Password... и устанавливаем секретный пароль, после чего не забываем применить кнопкой Apply. Настройки беспроводной сети я задал в главном меню Quick Set, где SSID это имя беспроводной сети. Ставим галочку в чекбокс WPA2 и в поле Pre-Shared Key пишем 8-ми символьный пароль. Жмем Apply, перезагружаем роутер.

Дальше меня попросили закрыть доступ к развлекательным ресурсам и поставить запрет на скачивание всякой всячины. Хозяин барин, поехали! Блочим не торенты, а передаваемые файлы.

Что бы не загружали и не смотрели что попало, а работали, подойдет следующая терминальная команда.

/ip proxy access

Далее:

add path=*.exe action=deny

add path=*.mp3 action=deny

add path=*.zip action=deny

add path=*.rar action=deny

add path=*.avi action=deny

add path=*.mp4 action=deny

add path=*.mkv action=deny

add path=*.mov action=deny

add path=*.wma action=deny

add path=*.flv action=deny

add path=*.waw action=deny

Такие дела мои юные любители ЭВМ и радио электроники. Готово. Как видим, настройка оказалась не такой сложной. В целом роутер MicroTik оказался весьма серьезной коробкой, предназначенной для серьезных дел. Главной задачей установки роутера MicroTik было стабильное поведение и раздача сети более чем 20 беспроводным клиентам. Ставить его в офисные помещения самое оно! В нем еще очень много настроек — всех мыслимых и немыслимых возможностей, которые предоставляют более известные бренды за весьма круглые суммы. Сам роутер я сегодня купил за 1950 рублей. Не вздумайте его покупать, если читаете эту статью, ведь намучаетесь и потом плакать будите! Шутка:) Хорошего дня, и приятного использования!


Ваши соображения
Как вас зовут
Электропочта для ответа

Расскажите о неисправности

Ваш адрес

Например, так: ст. м. Медведково, ул. Полярная дом 28, кв. 45


Дата и время для визита

Например, так: «18 августа, в 18 часов» или «Завтра вечером»


Как вас зовут

Контактный телефон +7

Например, так: 9051234567


ОтправитьСтрелочка